MetaTrader Update Required

After the 1st March 2019, MetaTrader 4 desktop terminal builds below 1118 and MetaTrader 4 Android terminals below 1104 will no longer be supported. Older terminals will not be able to connect to FXOpen UK trading servers.

We recommend updating your servers to build 1170 released on December 20, 2018. The update features error fixes and platform stability improvements.

Download MetaTrader 4 Desktop  Download MetaTrader 4 Andriod

The FXOpen UK Team E-mail: [email protected]

The FXOpen AU Team

E-mail: [email protected]

Back